[Date Prev][Date Next][Thread Prev][Thread Next][Author Index][Date Index][Thread Index]

Set & Table hierarchy

Date: Thu, 9 Nov 89 10:33:36 PST
   From: ravi (Ravi Pandya)


	   ScruSet<Heaper> :: count() stepper()
		   isEmpty() hasMember(x) isSubsetOf(s)
		   mutable() immutable()

What do the "mutable" & "immutable" messages to a ScruSet mean?  I can
think of several possibilities.

1) make mutable & immutable versions of this ScruSet, starting from a
current snapshot.  In which case, it should be called "asMuSet" and

2) Is this ScruSet a MuSet?  Is it an ImmuSet?  In which case the
messages should go away because their functionality is adequately
subsumed by "isKindOf".

3) make MuTable & ImmuTable versions of this ScruSet.  I can't figure
out what this would mean, but if this is intended, let's call these
"asMuTable" and "asImmuTable".

In short, I think our pun has destroyed the utility of "immutable" as
a general descriptive word that can apply to non-Tables.  The general
terms become "Mu", "Immu", and "Scru"; used as prefixes.  Aren't you
glad you came up with these puns {-;?