[Date Prev][Date Next][Thread Prev][Thread Next][Author Index][Date Index][Thread Index]

Names for tables

Date: Sun, 22 Oct 89 13:25:59 PDT
   From: ravi (Ravi Pandya)

   How about ImmuTable for SEFTable & ScruTable for ROTable? :-)

I love it.  As you can see, it seems to already be catching on.  I
further propose

	MuTable	 instead of Table or TableBang.
	ImmuSet  instead of Set
	MuSet    instead of SetBang (which is a shame.  All of 30
                        people would have appreciated the pun though)
	ScruSet  instead of ROSet.

even though all Tables are ScruTable, let's use "Table" as the generic
when speaking, and "ScruTable" when we want to emphasize the ability
to scrutinize it, or to constrast with MuTables.  Similarly for
"Set"s.  The generic "Table" and "Set" should appear nowhere in the
code, but only in speech and comments.  I think this regularizes the
terminology substantially.

Heh, I think we're going to make substantial use of your token
oriented global search & replace utility.