[Date Prev][Date Next][Thread Prev][Thread Next][Author Index][Date Index][Thread Index]

RealIntegerTable }-%?

I just noticed what a confusing name this is.  The fault lies in the
"Real" prefix convention which I introduced to distinguish the
hidden implementation class from the abstract visible superclass.  I
didn't notice until now the conflict with numeric terminology.  We
need a better convention for this.  In order to prevent *everyone*
from beating up on me for attempting to change the terminology again,
I hereby suggest that we leave old names alone (except
RealIntegerTable), declare the old convention to be obsolete (but in
use), and use the new convention only for new things.

But only if someone comes up with a better convention.  Remember the
old Xanadu tradition: don't abbreviate, pun!