[Date Prev][Date Next][Thread Prev][Thread Next][Author Index][Date Index][Thread Index]

Re: Protocols for Smashing the State

Abstract: For once I argue for terseness.

> From mark Mon Nov 13 04:53:48 1989
> I don't at all like "merge".  What would be ideal would be a name that
> had the same relation to "union" that "+=" had to "+".  It'd be great
> if this turned into a general naming convention.  How about
> void MuSet::unionInto (Set *)
> with the "Into" suffix being the general convention?

Good idea, but how about "To" as the general convention?  I suspect
it will more often parse correctly out of the general case, and it's
a strong, snappy particle that says the victim object is having
something done >To< it.

("On" is awkward here, but might make sense even more often.  I suspect
 any particle will be awkward, though, since the normal way to name a
 side-effecting operation is with a verb, and with English the
 side-effecting case is the default, while edited copies need explaining.)