[Date Prev][Date Next][Thread Prev][Thread Next][Author Index][Date Index][Thread Index]
'hasValue' message for Tables
- To: <heh>
- Subject: 'hasValue' message for Tables
- From: Eric Dean Tribble <tribble>
- Date: Wed, 25 Oct 89 17:25:47 PDT
- Cc: <xtech>
- In-reply-to: <Hugh>,07 PDT <8910251842.AA05558@xanadu>
Date: Wed, 25 Oct 89 11:42:07 PDT
From: heh (Hugh Hoover)
how about 'includes' or 'contains' or 'includesKey' ?
My original suggestion was 'includes'. MarkM's objection that also
applies to 'contains' is it makes equal sense to have the argument be
another collection. Testing something akin to set inclusion. With
the advent of ObjectAsPosition objects, we could actually just
overload the same message name, but I'd prefer two distinct and
descriptive names. I like 'includesKey'. Other alternatives are
'hasKey', 'hasPosition', and isBound or some such.
nothing against hasValue, except that there is a blurring whether it
means hasDomainValue or hasRangeValue...
I was thinking of key-value pairs. My interpretation was 'table
hasValue for the supplied key'.
I assume you mean hasDomainValue.
more like hasRangeValueForDomainKey: - what a mouthful!