[Date Prev][Date Next][Thread Prev][Thread Next][Author Index][Date Index][Thread Index]

UnaryFns & Tables

Oops.  I noticed an interesting terminological gotcha waiting to
pounce on us.  "compose" on Tables corresponds to putting a bunch of
RestrictedUnaryFns together into a RestrictedSet, but is completely
different than "compose" on UnaryFns themselves.  I propose that we
rename "compose" on Tables to be "occlude".  This is more descriptive,
and shouldn't cause anyone any pain, as no one uses "compose" on
Tables now.  (At least, none of my code does.  Does anyone out there
remember ever composing Tables using "compose"?  Please answer
quickly.)  "compose" on UnaryFns is exactly function composition, and
so should be left alone.