[Date Prev][Date Next][Thread Prev][Thread Next][Author Index][Date Index][Thread Index]


I propose we shoot Ravi for proposing them, then adopt ImmuTable and
SrcuTable, and MarkM's MuTable.  Since they are abstract classes, the
corresponding names for Sets should also be abstract.  Using the names
for the Set hierarchy is fine.  Since we'll be using
pseudo-constructors, they won't get in anyone's way.

Another dimension of variation is multiplicity of values (Set vs.
Bag).  I think the basic abstraction above Sets should be Bags.  Sets
are a subclass with a particular strange property on them.  What's the
corresponding property for Tables?  Multiple values for a single key.
Less useful, to be sure.  Hmmm...